1

I've started using google pagespeed service and now when I check my site on http://validator.w3.org/ with doctype HTML5 and encoding UTF8 - I'm getting more than 80+ errors and 95% of them are errors to do with pagespeed

Egs of errors are

Attribute pagespeed_no_defer not allowed on element script at this point

Attribute pagespeed_lazy_src not allowed on element img at this point

Any idea what I should do about these

Thanks

3
  • Are those causing problems for actual users, or is it only the validator that is complaining? Aug 31 '13 at 10:19
  • Not causing any other problems. Just wanted to be sure its not effecting any SEO
    – Gublooo
    Aug 31 '13 at 10:53
  • You should get it validating as much as possible to ensure that your website is compatible with most if not all browsers. Some browsers will render the page with no problem as they have error correcting, some browsers are better at this than others. But as Steve said, w3c doesn't relate to page speed. Aug 31 '13 at 19:52
1

I wouldn't worry about those errors. I'm not sure why pagespeed is putting those attributes in, but they don't seem to be hurting anything other than causing validation warnings.

As far as SEO goes Google Says Pages That Validate Do Not Get Ranking Boost. So having a few validation problems won't cause any problems on that front.

1

You must be copying the pagespeed markup into the validator or validating from that page. If you want to get a valid report, you must point the validator to your page and not at the markup in the toolbar (assuming that's what you're doing). Pagespeed does not insert anything into your server markup.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.