1

I have a joomla website on shared hosting at siteground.com

in the control panel, i see this message that i have exceeded my inode usage of 150,000.

any tips to reduce this?

  • Hey Vivek, did either of those answers help you out? – Christopher Feb 14 '11 at 19:14
2

This question on Stack Overflow suggests that deleting files should help. If you have multiple WYSIWYG editors, remove all that you don't need. Some of the editor plugins (like fckeditor) have an unbelievable number of files.

However, since it's shared hosting it's likely that the message is caused by the number of files across all the sites on the server. I would contact your host about it; they probably have too many sites on one server.

1

You may want to consider changing the cache settings of your Joomla! website as well to reduce the number of inodes. For an interesting case study on how the number of inodes was reduced dramatically for a shared hosting site that has a maximum of 150,000 inodes, see:

http://www.test.developmentwork.net/data-recovery/joomla-test-sites/35-using-a-subdomain-as-a-joomla-test-site

By changing the cache settings and clearing the cache regularly, the number of inodes was reduced from over 450,000 to some 80,000.

By managing your cache settings effectively, you may be able to run up to 10 subdomains with Joomla! installed if traffic is not too heavy and you do not run too many scripts on a shared hosting account with a maximum of 150,000 inodes.

Gregory

0

I suggest you change your hosting... Joomla files already exceed 9000+ and with adding new extensions and files it will be hard to keep removing files like that

0

It is the total number of files. Just reduce your files by removing unnecessary modules, templates and reducing cache clean up time.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.