I have a MediaWiki deployement at:


I have been importing templates from Wikipedia and am receiving a Lua error for the Convert template; the error is:

Lua error: Internal error: The interpreter has terminated with signal "11".

The error can be seen here (you have to click on one of the 'Script Error' messages): http://wiki.tankpedia.org/index.php?title=M2_Light_Tank

The Scribunto deployment this is dependent on is chmod to 755.

The following error also appears on the same page:

Expression error: Unrecognized punctuation character "["

Research online suggests this relates to the ParserFunctions extension however it is installed; I even added the following extra line in my config file and it did not help:

$wgPFEnableStringFunctions = true;

I reinstalled ParserFunctions Version 1.5.1 as well as trying Version 1.4.1; the reinstall of the first and trying the second both failed to resolve this issue. I also tried chmod the ParserFunctions deployment to 755 to see if there was a permissions issue; it did not help.

  • What OS are you running? I have exactly the same issue with error code 11. – Mastergalen Jul 14 '13 at 19:11
  • Thanks for the reply. The underlying OS is CentOS; this is a classic LAMP deployment. – Gedalya Jul 14 '13 at 20:45

I had the exact same issue. Signal 11" would tend to indicate that the standalone Lua interpreter that is shipped with the extension has crashed.

Instead, run the Lua interpreter that should already be pre-installed on your server. For some reason the Lua binaries packaged in the extension do not seem to work.

Run the lua command via SSH. Check that your server is running version 5.1.x. Note that for Scribunto the version has to be 5.1.x.

Lua's default installation path is in /usr/bin/lua.

Then in your LocalSettings.php set:

$wgScribuntoEngineConf['luastandalone']['luaPath'] = '/usr/bin/lua';

to fix the issue.

If running the Lua command shows it as undefined, then you could try installing it with yum install lua, though I am not sure if the version would still be 5.1.x

  • This solved my problem. To be clear I had to install Lua as noted above and reference it in the LocalSettings.php file. Installing Lua requires downloading the appropriate source and compiling it on the target machine and then installing it (the compilation and installation can be one step). The Lua source can be found here: lua.org As noted above messages; I am using CentOS. I tried to install Lua 5.2.2 (the latest as of writing this) and it failed. I was successfull with 5.1.4; I used thsese notes: flylabs.com/articles/2011/11/04/installing-luarocks-in-centos – Gedalya Jul 15 '13 at 15:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.