I am getting my hands wet with ASP and I have been following the tutorials. I deployed the site and in Azure and it worked great. Today I started actually designing the site. And when I published, it looks as if it doesn't read any of the files I just updated, added, and modified. It works on my localhost, but not in the Azure. I thought when you publish, everything goes up, including the new files.

I don't have enough reputation to add a picture so, you'll forgive me.

SO, basically, how do I get my entire site uploaded?

In case anyone does stop by, I was able to pull this out just recently:

CA0058 Error Running Code Analysis CA0058 : The referenced assembly 'DotNetOpenAuth.AspNet, Version=, Culture=neutral, PublicKeyToken=2780ccd10d57b246' could not be found. This assembly is required for analysis and was referenced by: C:\Users\lotusms\Desktop\LOTUS MARKETING\ASP.NET\WebsiteManager\WebsiteManager\bin\WebsiteManager.dll, C:\Users\lotusms\Desktop\LOTUS MARKETING\ASP.NET\WebsiteManager\packages\Microsoft.AspNet.WebPages.OAuth.2.0.20710.0\lib\net40\Microsoft.Web.WebPages.OAuth.dll. [Errors and Warnings] (Global)

CA0001 Error Running Code Analysis CA0001 : The following error was encountered while reading module 'Microsoft.Web.WebPages.OAuth': Assembly reference cannot be resolved: DotNetOpenAuth.AspNet, Version=, Culture=neutral, PublicKeyToken=2780ccd10d57b246. [Errors and Warnings] (Global)

Could this have something to do with the problem?

  • Sometimes the compiled part of the site doesn't get recompiled when you upload new content. It may help to stop and start the website using the IIS manager. Or if the worst comes to the worst, delete \Windows\Microsoft.NET\Framework\(version)\Temporary ASP.NET Files\(site name)
    – Mr Lister
    May 15, 2013 at 14:38
  • Mr Lister, Thank you so much for your help. Do you mind specifying a little more what you mean. I am completely noob at ASP. How do I start the website in IIS Manager? and what negative impact will I experience if I delete that file? By the way, I just went to that folder and is empty
    May 15, 2013 at 14:44
  • In the Internet Information Manager, navigate to your website and select "Stop" from the right-click menu. Then select "Start" again...
    – Mr Lister
    May 15, 2013 at 14:50
  • Ok, I did that, but nothing happened
    May 15, 2013 at 14:58
  • I'm not exactly an expert in this field, sorry; I was hoping that by now someone more knowledgeable would have come by.
    – Mr Lister
    May 15, 2013 at 18:49

1 Answer 1


After many hours of research I found nothing wrong with my code and had several guys look at it. I decided to delete the site at the server, recreate it, and re-deploy my files into a fresh site. And it worked!

My apologies for the troubles. It seems Azure had some problems to begin with. Looks like I will be leaving them soon.

Thanks for your time

Not the answer you're looking for? Browse other questions tagged or ask your own question.