4

I'm using a Perfect Web contact form on my Joomla 2.5 website. The contact form emails all the info when a user fills it in and sends it to my Gmail account which in turn forwards it to my office email account for us to reply.

However, I just noticed that the emails are being marked as spam or as phishing by Gmail:

This message may not have been sent by:...

And get rejected as spam when forwarded to my office email account. How can I get around this so that all my emails get forwarded?

2

You have at least two options to get around this:

  1. Add the sender address, which you added to the Joomla! configuration, to the whitelist of your Gmail account.

    Alternatively...

  2. Re-configure Joomla! to use an SMTP account to send the mails instead of using the internal mail function.

0

Check your original email header and see if Google says it SPF pass. It is common issue to forget adding SPF pass in the name server configuration. Or paste it here so that we can check it.

If it is SPF pass then as nibra has says, add the sender address in your gmail white list and also check if you email does not contain any spam words.

0

Use SMTP sending on global configuration in Joomla, and insert your e-mail account access data here (to be extra careful with security, place configuration.php outside public_html. You will find several documents on how to do that on the internet).

Use a VALID account, registered at your host, on your domain

Preferrably, don't set a different "reply to" e-mail

make sure your account have SPF and DomainKeys enabled

Check spamhaus and other resources to see if you are not blacklisted

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.