I've been developing a site with MAMP which has a handy way of generating (obviously) unverified SSL certificates for testing purposes.

All was well when testing with Chrome, Firefox, Safari you simply have to acknowledge the suspicious certificate once per session and that's that.

When I fire up (in Parallels since I'm on a Mac) to test Internet Explorer I get the same warning about the certificate but I hit "yeah ok, let's do this" and the server returns a 403 error?

up vote 0 down vote accepted

This blog explains what's happening:

After enabling HTTPS for a certain VHOST (within MAMP, but that is probably not relevant), Internet Explorer 8 started denying to display any HTTPS enabled page, showing a 403 Forbidden error instead. This problem occurred because of the following setting in my Apache configuration…

In your Apache SSL config — MAMP stores as a user template, go to File > Edit Template > Apache > httpd-ssl.conf and find the SSLStrictSNIVHostCheck directive (or simply add it) and set it's value to off:

SSLStrictSNIVHostCheck off

Now IE should be good to go with the rest of the browser gang.

Your Answer

 
discard

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.