0

I've decided to add a Like button to one of pages on my website.
The button appears, but it can't be clicked (i.e. nothing happens)

I've tried both iframe and XFBML with different settings, but nothing helped.

Here is an example of not working button

What can I do to fix the problem?

Additional information can be provided if needed, just write a comment.

1

The code on your site doesn't look like the code that is generated using the like button generator. Have you used the generator? It looks like you're mixing and matching two different ways of producing the box. Also, in your script tag, you have a line that says: 'your app id'. I would imagine that you would have to change that to something meaningful.

| improve this answer | |
  • I don't have any app id. Changed back to iframe, but that also doesn't work. – user1599 Oct 27 '10 at 18:47
  • And that page is just a test. I did use the like button generator, I just had to include Facebook SDK – user1599 Oct 27 '10 at 18:49
  • Did you try filling out the generator and getting the code from that? Also, do you have JavaScript enabled? – Virtuosi Media Oct 27 '10 at 18:50
  • Try it without the SDK. – Virtuosi Media Oct 27 '10 at 18:50
  • XFBML way cannot work without the SDK. Currently at the example page (in the question) there is iframe way: the code from the generator. – user1599 Oct 27 '10 at 18:52
1

The error I see right off the bat is that you are trying to use the FBML tags (Example, fb:like). They can only be used within a Facebook application.

Try this... http://developers.facebook.com/docs/reference/plugins/like

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy