I want to preview my website by manipulating the hosts file, linking to the server's URL but it's not working - My browser always tells me "the connection has been reset during page load".

What am I doing wrong? I edited my hosts file like many tutorials out there suggest and I checked (wireshark) that the browser connects to the correct IP (that of my server).

Yet, I can't see anything of my website...?


Make sure the IP you put into your host file is the one Plesk is actually using. This is an easy mistake to make if your server has multiple IP addresses.

Also, make sure you put www.domain.com and not just domain.com in your host file. It will need to match exactly to what you wish to test with.

If you have a later version of Plesk with the Nginx proxy. Try turning it off for testing. Based on your error this could be the problem.

Lastly, clear your browser's cache. I've seen the Plesk default page get cached and give odd results.

  • I added the IP I can view under the Tab "Websites & Domains". The domain matches exactly that I entered in Plesk. But I added a www.-Version anyway to the hosts file, but it still aborts the connection.
    – F.P
    Feb 19 '13 at 7:55
  • Found this post helpful. The listed IP addresses when I created the account in plesk did not include the server's IP. I added it via "Tools & Settings -> Tools & Resources -> IP Addresses -> Add IP Address". Im not sure if this was just something to do with how our managed server was set up by the vendor or if this is inherent to how plesk operates by default. Either way, my problem was that I had the incorrect IP selected for the domain. (Plesk v11.5) Jun 19 '14 at 16:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.