3

I have a large collection of Windows exe files which are being stored/distributed using Amazon S3. We use signed URLs to control access to the files and this works great except in one case when trying to download a .exe file using Internet Explorer (version 8). It works just fine in Firefox. It also works fine if you don't use a signed URL (but that is not an option).

What happens is that the IE downloader changes the name from 'myfile.exe' to 'myfile[1]' and Windows no longer recognizes it as an executable. Any advice would greatly be appreciated.

Thanks.

4
  • 1
    Did some searching and looks like IE has a bunch of issues with handling downloaded files. Kinda sad really.
    – John Conde
    Commented Oct 22, 2010 at 19:57
  • Yeah, so far the best thing I have seen is to add a .removeme option to the end of the filename which I'd rather not do. Commented Oct 22, 2010 at 20:49
  • Have you tried different Content-Type meta tags/file names that are unlikely to have been downloaded already?
    – Metalshark
    Commented Nov 3, 2010 at 12:44
  • Was John's link helpful for you? Commented Feb 14, 2011 at 19:49

1 Answer 1

2

Looks like someone found a solution for this problem. Apparently you need to send the proper content-type header.

THIS IS HOW YOU FIX IT

In A3 Click on your .exe file choose Actions and bring up properties

Choose Metata Data

Add more metadata

Choose Key: Content-Disposition Value: attachment

then type this after attachment; filename=yourfilename.exe

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.