I have a CMS on my site that utilises TinyMCE (the WYSIWYG text editor). The issue is that TinyMCE cannot browse for files (example: images) on the web server. I get the error:

Error 324 (net::ERR_EMPTY_RESPONSE): The server closed the connection without sending any data.

I have been told this may be occurring because the server is configured to limit the folder depth for running scripts.

Unfortunately I am primarily a front end developer so I am not really sure how to go about changing/viewing this.

I have access to WHM and cPanel. Does anyone know how to adjust this?

  • Must admit, I have not heard of such a "folder depth limit", other than that imposed by the OS (that doesn't mean there isn't one). What OS and webserver are you using? If there is such a limit then I imagine this will be outside the realm of WHM and cPanel - just a hunch.
    – MrWhite
    Jan 18 '13 at 10:41

I found good site which was helpful to solve the error:

Error 324 (net::ERR_EMPTY_RESPONSE): The server closed the connection without sending any data.

You can browse this site if you want to know more about it..

I went to browser shortcut and changed target properties to "C:\Program Files (x86)\Google\Chrome\Application\chrome.exe" --use-system-ssl.

...adding --use system-ssl on the end and it worked.

On an XP computer: "C:\Program Files\Google\Chrome\Application\chrome.exe" --flag-switches-begin --disable-ssl-false-start --flag-switches-end.

...just adding --flag-switches-begin --disable-ssl-false-start --flag-switches-end.


I too had problems with cPanel/TinyMCE integration when it came to handling files. I had to bump up the following to allow larger files to be uploaded through TinyMCE using the images plugin (I believe all of these are in php.ini or accessible through WHM's UI):

  • max_execution_time
  • max_input_time
  • memory_limit
  • post_max_size
  • upload_max_filesize

Also, make sure the folder you're trying to upload images to is set to 755 (or whatever permission you need, personally, as long as owner can write).

But, in particular, this sounds like a browser issue: Are you using Google Chrome? It seems to be the common culprit related to this problem, according to the Interwebs. Try Firefox or Safari- the issue may not be your code/server after all.

  • Ah thanks - Yeah I dont think its a browser issue. Firefox gives me the error: 'The connection to the server was reset while the page was loading'. Safari just gives a blank page. I've tried to modify those in htaccess to no available.
    – MeltingDog
    Jan 20 '13 at 23:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.