PROBLEM: Trouble shooting LDAP connection binding and request resolution

ERROR: "LDAP Bind failure for user . Error -1: Can't contact LDAP server"

SOLVED "Authentication with the LDAP server succeeded."

  • It would be helpful if you provided a few more details up front. Vague questions like this are a good way to get down-voted. – BenV Oct 22 '10 at 2:05

It means it couldn't connect to the LDAP instance you specified.

  • Make sure your configuration under Administer >> Site Configuration >> LDAP Integration is correct. You can refer to the documentation here.
  • Try connecting with an LDAP client like JXplorer to validate that your LDAP instance is up an running at the host and port you think it is.

If you want a better answer you'll have to provide more details.

| improve this answer | |
  • @BenV: What information would be of use? I've looked at 100s of pages related to it, tried lots of stuff. If you read the comments on the page you linked to, you'll notice a common theme... the documentation is superbad, if not plain wrong. I've tried coding a basic LDAP connection by hand in PHP, but couldn't get it to work (as a control test)... here's the post on that: stackoverflow.com/questions/3993128/… happy to answer ANY and All questions, just can't believe someone would take the time to code something like this and not have feedback test. – blunders Oct 22 '10 at 2:45
  • @blunders: From tinyurl.com/so-hints: What did you expect it to do? What are you trying to accomplish? What have you already tried? What happened in those attempts? Be detailed: in particular, if something didn't work, don't just state that: tell us how it failed. If it threw an exception, what was the exception? (Don't just give the type - give the error message and say which line threw it. If there's a nested exception, post that too.) – BenV Oct 22 '10 at 3:15
  • @blunders: see updates in my answer above. – BenV Oct 22 '10 at 3:20
  • @BenV: Posted some more info, not sure if it's of any use. – blunders Oct 22 '10 at 4:20

I'm not sure if this is the same problem you're having, but you might look at this: http://drupal.org/node/99009

| improve this answer | |
  • @Adam Thompson: Thanks, and yes, I've seen that page. In some cases, OpenLDAP 2.3+ (I believe) it requires a SSL-CERT by default, "TLS_REQCERT never" turns that requirement off. I've tried that, but received the same error. Do believe both Apache and PHP are working right, but super hard to tell... :-) – blunders Oct 22 '10 at 2:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.