Having finally completed my web site, I submitted it and a sitemap to Google at the beginning of December.

A look at the index status today, 29/12/12, shows 0 indexed, and 5 Not selected.

I can live with the 0 indexed at this stage because, as I understand it (which might be not at all!), indexing takes time and is also reliant upon back links??? However, the bit that's got me puzzled is the 'Not Selected' part. Having read the help attached to the 'Not selected' icon, it seems that it ignores pages that are duplicate or redirected. However, I'm sure my pages are all completely different! I have a home page, a bookings page, a contact us page, a gallery page and one or two others, none of which is like another. And as for redirects there are none!

What does this result mean?

  • I like the responsive design of your site... just a point however, on the "Getting Here" page, the map pointers start to jump around when the browser width exceeds 1100px and at larger screen sizes they are off the map!
    – MrWhite
    Dec 29, 2012 at 11:33

1 Answer 1


Your site is certainly indexed, site:www.holiday-home.uk.com returns results. Note that it is the www version of your site that is indexed, and this is the URL that should be referenced in GWT. It looks like you have probably linked the bare domain (holiday-home.uk.com) in GWT instead (which is not indexed).

But... the bare domain is also accessible. eg. holiday-home.uk.com and www.holiday-home.uk.com both return the same page (this could be perceived as duplicate content - only one of which will be indexed). Ideally you should be redirecting from one to the other (or specify the preference in GWT - but this only benefits Google). If you prefer the www subdomain then set up a 301 redirect from non-www requests to www.

Also, both www.holiday-home.uk.com/ and www.holiday-home.uk.com/index.html refer to the same page. These are strictly speaking two different URLs and consequently they could be seen as duplicate. It is preferable to not show the directory index document ie. index.html in the URL. Either redirect (careful to avoid a redirect loop) or set a canonical meta tag.

Your XML sitemap includes www in all URLs except one:

  • Firstly, I have amended the 'gettinghere' page. It's now a little more static and should work better on different screen sizes. I have also added canonical 301 redirects to .htaccess and a link tag to index.html redirecting to the main domain holiday-home.uk.com. Hopefully I have done it all correctly. Please let me know if I've done something incorrectly or if you spot any further errors on the site. Thanks again for your time and help! Jan 2, 2013 at 9:58
  • @LangdalePikes: Your 301 redirect appears to only work for the home page. eg. holiday-home.uk.com/accommodation.html does not redirect.
    – MrWhite
    Jan 2, 2013 at 10:46
  • Oh no! Thanks for getting back to me! I have added this to .htaccess... Options +FollowSymLinks RewriteEngine On RewriteCond %{HTTP_HOST} !^www\.holiday-home\.uk.com$ RewriteRule (.*) holiday-home.uk.com/$1 [R=301,L] and this ... <link rel="canonical" href="holiday-home.uk.com" /> To index.html but nothing to the remaining pages because I thought the 301 redirect in .htaccess would cover those. Is what I have done correct? If not, what should I have done? Jan 2, 2013 at 11:19
  • Your code looks OK. Yes, this should work for all pages on your site. Do you have any other (possibly conflicting) code in .htaccess?
    – MrWhite
    Jan 2, 2013 at 13:00
  • Hi, yes there was a redirect to force the use of gzipped files... <FilesMatch "\.(js|css|html)$"> RewriteEngine on RewriteCond %{HTTP:Accept-encoding} gzip RewriteCond %{REQUEST_FILENAME}.gz -f RewriteRule ^(.*)$ %{REQUEST_URI}.gz [L,QSA] </FilesMatch> I have removed this stuff and I think it's working now but will keep testing... Thanks again! Jan 2, 2013 at 13:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.