5

I have the domain http://dropbox.tombrito.com/ (on GoDaddy) forwarding with masking to www.dropbox.com/sh/k6ypvx4y4kf0gu6/rdjxQ1b1OL

It was working fine some time ago, but now the result is a blank page (although the Dropbox's favicon appears correctly in the browser's tab title).

The DNS manager shows me a single entry with the name "dropbox":

 A  dropbox 64.202.189.170

Any idea what's wrong?

Related: Why my domain redirect on Google Apps is returning 404?

6
+50

Masked forwarding uses frames to display the site being redirected to. For dropbox that does not appear to work. You may want to use use a regular redirect instead.

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01//EN"
   "http://www.w3.org/TR/html4/strict.dtd">
<html>

<head>
  <title>dropbox.tombrito.com</title>

</head>
<frameset rows="100%,*" border="0">
  <frame src="http://www.dropbox.com/sh/k6ypvx4y4kf0gu6/rdjxQ1b1OL" frameborder="0" />
  <frame frameborder="0" noresize />
</frameset>

<!-- pageok -->
<!-- 06 -->
<!-- -->
</html>
  • The masked forwarding worked for some months. Maybe something changed in the Dropbox website? Not sure. Anyway, thanks for the workaround! – Tom Brito Dec 10 '12 at 11:16
  • 2
    HeatfanJohn is correct dropbox is now sending the X-Frame-Options SAMEORIGIN header which will prevent most modern browsers from loading the page inside of GoDaddy's iframe. Try a changing dropbox.tombrito.com to a cname record pointing at dropbox. – AWinter Dec 11 '12 at 2:44
  • 2
    Forget the cname part of my comment. A full redirect is really you're only option at this point, short of integrating with the Dropbox API and building your own page to display available links. – AWinter Dec 11 '12 at 2:52
2

In Chrome's Inspector you get this error

Refused to display document because display forbidden by X-Frame-Options.

Two ways that should fix it:

  1. IFRAMES - Custom Domain Dropbox

  2. Add some PHP - Overcoming “Display forbidden by X-Frame-Options”

    <?php header('X-Frame-Options: GOFORIT'); ?>

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.