Why would URLs submitted in Google Webmaster Tools drop to 0? It's a small site, only like 20 pages, I submitted the XML sitemap and for about a week it said 20 URLs submitted. A day or so ago it indexed about 17 of the pages, but today when looking it not only says that 0 are indexed but also 0 have been submitted.

I did a site search on Google and found clearly that pages are indexed, is this just an error on Google Webmaster Tools?

1 Answer 1


If the pages can be found in the index, it sounds like the Sitemap itself might be the problem. Some troubleshooting ideas:

  1. Is GWT reporting a Sitemap error (see Issues column)?
  2. Does the Sitemap pass if you use the Test Sitemap function?
  3. Does the Sitemap itself load in a browser?
  4. Do the URLs in the Sitemap correspond exactly with what's actually on the site (and what's indexed)?
  5. Is there anything alarming under Health > Index Status?

If those don't reveal any problems, it may just be a blip in GWT. I've known such things happen and right themselves within 24 hours.

  • Thank you so much for the response. I'm thinking this may just be a blip because now the site in question is showing urls submitted, but another that previously did is now showing 0. That being said, out of all the troubleshooting ideas you listed everything passes, except for part of #3. When I test the sitemap in the browser it works completely is www is in front of the url, but without www I get this error in Firefox "Error loading stylesheet: An unknown error has occurred (805303f4)" and a blank page shows in Chrome.
    – ambient
    Dec 6, 2012 at 6:50
  • Actually, I guess #4 is slightly different, but only because not all the pages have been indexed, so it doesn't match exactly what is indexed, but it does match what is on the site. Anyway, I'm going to see how it plays out with the new site showing this issue and if it fixes itself, then I guess we'll call it a blip. Any ideas or thoughts on how to handle the error I'm experiencing without the www though?
    – ambient
    Dec 6, 2012 at 6:56
  • Looks like it might have something to do with the wordpress plugin I'm using -- rosamundwo.com/2011/solved-google-xml-sitemap-stylesheet-error -- I tried the 301 fix and it didn't work, so I'll try editing the function tomorrow.
    – ambient
    Dec 6, 2012 at 7:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.