My server works just fine on a normal Apache2 install. Now, I'm trying to install subversion on this server using a guide I found on the net called: Installation of Subversion on Ubuntu, with Apache, SSL, and BasicAuth.

However I get the following error:

(98)Address already in use: make_sock: could not bind to address

When I do grep -rH 443 /etc/apache2/ I get results in two files: ports.conf and sites-enabled/default-ssl

I tried it both with and without that last Listen 443 commented out, here's ports.conf:

NameVirtualHost *:80
Listen 80

<IfModule mod_ssl.c>
    NameVirtualHost *:443
    Listen 443

<IfModule mod_gnutls.c>
    Listen 443

#Listen 443

And the first few lines of default-ssl

<IfModule mod_ssl.c>
<VirtualHost *:443>
        ServerAdmin webmaster@localhost
        SSLEngine on
        SSLCertificateFile /this/isnt/relevant/probably.pem
        SSLProtocol all
        SSLCipherSuite HIGH:MEDIUM

And netstat -an --inet | grep 443 returns nothing.

Any ideas?

1 Answer 1


I fixed it myself when I commend these lines out in ports.conf

<IfModule mod_gnutls.c>
    Listen 443

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.