I run Google Apps email and have traditionally hosted my own DNS records through my Plesk setup. It has been recommended to us that we'd more reliably serve emails during downtime if we kept the MX and CNAME listings required by Google Apps hosted at Enom instead of handling it internally.

I have essentially copied the settings from Plesk over to Enom. The domain itself forwards with no problem, but the MX records, while they seem to be input into Enom without error, never seem to reroute my mail. If I try to send to the email address I'm trying to route, I get the following error bounced back:

Google tried to deliver your message, but it was rejected by the recipient domain. We recommend contacting the other email provider for further information about the cause of this error. The error that the other server returned was: 553 553 sorry, that domain isn't in my list of allowed rcpthosts (#5.7.1) (state 14).

This sort of error gets referenced a lot with regard to propogation, but It's been two days and Enom updates everything else almost instantly.


  • header: MIME-Version: 1.0 Received: by with SMTP id r6mr4076294wbw.26.1285890102711; Th= u, 30 Sep 2010 16:41:42 -0700 (PDT) Received: by with HTTP; Thu, 30 Sep 2010 16:41:42 -0700 (PDT= ) X-Originating-IP: [] Date: Thu, 30 Sep 2010 19:41:42 -0400 Message-ID: <[email protected]> Subject: test From: Daniel Horton <[email protected]> To: [email protected] Content-Type: multipart/alternative; boundary=3D0016e659f7e0cad5b40491829eb= 0 Sep 30, 2010 at 23:48

2 Answers 2


You might be waiting on the TTL (regardless of how quickly eNom updates their DNS records, the TTL will likely be observed by intermediary systems which have cached the MX record), however, the more likely culprit after 48 hours would be your Plesk settings.


My apologies - I got the impression from your question that you were duplicating your Plesk settings at eNom for redundancy, though the header you provided would indicate otherwise.

From a review of the headers you provided, it looks like eNom is not returning any MX records - see mx:nativeapps.org at MXToolBox (you may want to keep checking what eNom's nameservers return for your domain as you investigate with their support staff).

  • Yeah, TTL was set to 5 minutes when I initially tested. I've since raised it. And Plesk mail is turned off completely for the domain in question, as is the DNS since it's being handled elsewhere. Sep 30, 2010 at 23:49
  • Thanks for getting back. It wasn't the TTL, but your comment made me certain it was something with the way Enom does things. Further investigation revealed that my hostname field (which in Plesk needed the domain name to be entered) needed the @ symbol used in Enom (which is a fill-in for "none" apparently). I wrongly assumed MX settings would be entered using the same syntax regardless of where I was hosting. Oct 1, 2010 at 12:26

One comment, one idea:

The comment is that this question is probably better served at serverfault.com or superuser.com (I honestly don't know which one is most appropriate).

The idea is that you should include the full bounced mail headers in your question, and state which exact domain is having this problem. DNS is a public system, so once we know what domain it is, we can look at the information you're publicizing in DNS and tell you where the problem is.

  • Well, I'll post the headers here (I'll post as a comment above) just in case it gets answered, but I'll try posting on another site as well if nobody gets back. Seemed like this was something "webmasters" would find appropriate, but I take your point quite well. Thanks. Sep 30, 2010 at 23:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.