I've got a domain that I apparently forgot to set a preferred domain for, so I just tried to do it. Webmaster Tools instead popped up a little box:

Part of the process of setting a preferred domain is to verify that you own http://www.example.com/. Please verify http://www.example.com/.

I'm running into some problems following these instructions:

  1. As far as I can tell I already did verify sometime in the past. There's a TXT DNS record with the gibberish Google tells you to set for it that I couldn't have come up with myself.
  2. …and nothing is telling me this information is bad.
  3. So let's assume the site is somehow not actually verified. All the various methods' instructions start with "click the Manage Site button next to the site you want, and then click Verify this site." That button doesn't even exist on my screens. (It presumably goes away when you successfully verify?) Those instructions were all updated pretty recently, and the DNS one in particular just a couple weeks ago so it seems a bit unlikely they're inaccurate.
  4. I am not using Apps, and won't be, so can't try out the verification through there.

Note that I also have another domain that I have not done any verification for which is showing the same behavior(no such button, being told to verify when it seems impossible etc.) so something appears to just be broken.

I already have a no-www process in place server-side, so we can skip that. I'm just trying to get the box checked off in GWT.

If I don't get any resolution, I'll eventually scrap the TXT record and see if the site gets un-verified(or whatever since it thinks it isn't), and see if I can just restart the process. It's not urgent so I'm just trying to figure out if I've gone blind to something or what. Did the button move?

  • I was having the same problem but verifying both the www.example.com and .example.com then selecting on or the other for your preferred domain. Doesn't really make senses but it did the trick.. thanks.
    – user19300
    Oct 20, 2012 at 20:08
  • Good question. All explanations here: support.google.com/webmasters/bin/….
    – Zistoloen
    Jan 8, 2013 at 15:05

2 Answers 2


If you have both www.example.com and example.com listed in the Webmaster Tools homepage already, try deleting the entry for www.example.com (under Manage site > Delete site) and then re-add and re-verify the record for www.example.com before setting the preferred domain.

If you currently have only example.com listed on the Webmaster Tools homepage, you'll need to add www.example.com as a separate site before you can select the preferred site.

(You mention that you've verified it in the past, but it's not clear from your question whether or not both www.example.com and example.com are listed as sites on your homepage in Webmaster Tools; if they're not, they need to be in order to set a preferred domain. You can delete the non-preferred entry after you've verified and set a preferred one.)

  • 2
    It was as in your second paragraph. Which is just silly given the point is not wanting to see or deal with one of the versions. Instead now I have to see my domains listed twice for absolutely no useful reason. Also they say you may have to do this; apparently it's a little stronger than that. Would be nice if after selecting one it at least collapsed them together under the chosen one.
    – Su'
    Aug 20, 2012 at 5:04
  • 1
    @Su' I have always deleted the “non-preferred” domain after setting the preferred one. I can't point to any official docs from Google that say it's OK to do this, but I haven't noticed any downside so far.
    – Nick
    Aug 20, 2012 at 8:46
  • Ha. I can't decide if the existence of that loophole just makes me even more irritated about it. I'll give it a shot, though.
    – Su'
    Aug 20, 2012 at 9:40
  • I had same problem, it was fixed if you add all 4 variants of your website http/https with/without www. It's silly requirement.
    – Tien Do
    Apr 11, 2018 at 9:10

I run into the same problem, added both www and non-www, removed them, added again, verified both with multiple methods, but nothing. Finally I found out that I added https versions only and that is not enough for Google, and after I added both www and non-www with http (so actually FOUR versions of the same domain), finally Google let me set the preferred option.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.