I have been using the htpasswd generated in this question and it seemed to have been working well until recently.

Since yesterday, I am not able to access the newest file created in the folder ChatLogs(named 10_07_2012.txt). The server returns a 403 Forbidden error saying:


You don't have permission to access /ChatLogs/2012/07/10_07_2012.txt on this server.

I am still able to access older files(until 09 July, 2012). At first I thought it might be because of file permissions, but they are the same as on other 9 files in the folder.

What could be the problem? Please Help.


As per w3d's suggestion, I completely removed my htpasswd and htaccess files. Restarted the apache2 server(using service apache2 restart) and I'm still getting the same 403 Forbidden error for all chatlogs created after 2012-07-10 00:00:00.

The chatlog files are created/modified using Lua and PtokaX. The chatlogging script is similar to this one

  • Are you saying that new files in the same folder as older (accessible) files are not accessible? In which case I don't see how it can be a .htpasswd issue, as this would affect the entire folder? Are the file owners the same?
    – MrWhite
    Jul 10, 2012 at 11:33
  • @w3d Yes, the files are in the same folder. And yes, the file owner is root for the files as well as folders. I am able to access 09_07_2012.txt in the same folder.
    – hjpotter92
    Jul 10, 2012 at 11:38
  • 2
    Have you tried removing the password protection altogether, to see if that is indeed the problem? Delete caches, try another browser...? What are the file permissions?
    – MrWhite
    Jul 10, 2012 at 11:54
  • @w3d OK, restarted apache2 after removing the htpasswd file. And I am still unable to access files created/modified after 09th July.
    – hjpotter92
    Jul 12, 2012 at 6:54
  • And... have you deleted caches, tried another browser, and what are the file permissions? Presumably you are attempting to access these files directly over HTTP? Are you able to access and download these files successfully over FTP? Is the content of these files as expected - no corruption? I'm not familiar with the scripting languages you mention unfortunately, but in the script you link to I cannot see how file permissions are specifically set on the written file, which presumably they would need to be if the script is running as root but the resulting file should be readable by everyone?
    – MrWhite
    Jul 13, 2012 at 0:56


Browse other questions tagged or ask your own question.