About six weeks ago my homepage (mayberrykayakingdotcodotuk) disappeared from the google organic search for "kayaking pembrokeshire" despite it having been number 2 within a few weeks of it's launch last summer. My previous site (www.mikemayberrykayakingdotcodotuk) had been 2nd for about six years and has 301 redirects for all pages to the new site. Google toolbar still rates the homepage as 3/10 and the domain is still showing in search results, just not the homepage.

A little research suggests that this is most likely to be due to an issue with google treating two pages as identical content (one with www. and one with not) since the changes in their algorithms around that time and that the way to fix this is to add some code somewhere. This makes sense to me as my print advertising doesn't have the www part of the address.

I have cpanel access but a limited knowledge on web coding, having picked things up as I've gone along and paid for designers etc., when needed. Would someone be able to let me know where I have to go to add the code and what code I need to add to redirect the crawlers to one page?

Or is there another issue that is causing this?


If you haven't already, generate a sitemap for your NEW domain (http://www.xml-sitemaps.com/), create a Google WebMaster Tools account (https://www.google.com/webmasters/tools/), and be sure to list your site under the URL you prefer (in this case, without the "www").

You can also adjust these settings in Google WebmasterTools under each individual site's dashboard > Configuration > Settings > Preferred Domain.

Within a few weeks (or less) you should see your organic rankings correct themselves, or at least have detailed feedback from Google as to what is causing the errors, etc, as they provide them in your WebmasterTools dashboard. It does take some time, though.

  • Thanks RCNeil. I have sitemaps set up and use wordpress which I understand sends a new map when I make changes to my site? – MIke Mayberry May 30 '12 at 16:27
  • I also have the Webmasters Tools set up and I have just been and changed the settings the suggest. It said that I should set up a 301 redirect also. Is that required and if so where do I go to do that? I've also sent a "reconsideration request" as I found some info on that. I do my own seo stuff through reading blogs etc., and don't believe I've done anything to be considered as black hat so not sure why the homepage would just fall of the organic search. – MIke Mayberry May 30 '12 at 16:33
  • If you have your OLD site submitted to Webmaster Tools, there is an option to notify them that you've moved your site. You can create a 301 redirect in your .htaccess file, and no Wordpress does not automatically submit a new sitemap, although the new pages will be indexed as Google continues to crawl your site periodically. – RCNeil May 30 '12 at 20:44
  • Thanks again RCNeil. I'm in the .htaccess file and it has the follwing code; – MIke Mayberry May 31 '12 at 10:18
  • # BEGIN WordPress <IfModule mod_rewrite.c> RewriteEngine On RewriteBase / RewriteRule ^index\.php$ - [L] RewriteCond %{REQUEST_FILENAME} !-f RewriteCond %{REQUEST_FILENAME} !-d RewriteRule . /index.php [L] </IfModule> # END WordPress I added; RewriteEngine On RewriteCond %{HTTP_HOST} ^mayberrykayaking\.co.uk RewriteRule (.*) mayberrykayaing.co.uk/$1 [R=301,L] and it went to www.mayberry.co.uk when I tested it. I removed it and it still goes there, which is worse than the problem I was trying to fix! Sorry to be a nusisance but can someone post the code to fix this? Thanks – MIke Mayberry May 31 '12 at 10:43

Not the answer you're looking for? Browse other questions tagged or ask your own question.