I need to run a website with just windows authentication. Given the following situation:

  • The location of the default website is: c:\inetpub\wwwroot
  • The location of my code is: c:\Sites\WebApp
  • My hostfile is edited so any .local i use points to
  • I am using Windows 7 professional
  • IIS version: 7.5

I have created a new application called 'AppX' underneath the default website and point it to c:\Sites\WebApp. It will use the DefaultappPool. When I switch off anonymous and switch on windows authentication all works well when I go to localhost/AppX/.

What I really want is a new website (No need to question why I want this). So I created a 2nd website and did exact the same creation of the application. Everything is the same; destination, app pool and authentication.

Now when I browse to this website web2.local/AppX/ I get the 401.2 - Unauthorized error. What am I missing here?

UPDATE: I also tried to create a new website directly pointing to the target folder. Same settings for authentication, applicationpool, etc. Same result as using an application in a new website.

  • To start I suggest checking access right on c:\inetpub\wwwroot folder and compare to the root folder for web2.local (even despite the fact that actual app is located in different folder).
    – LazyOne
    Commented May 30, 2012 at 12:03
  • I tried both. using %SystemDrive%\inetpub\wwwroot as destination for web2 and a different folder. Same result for both.
    – amaters
    Commented May 30, 2012 at 12:30
  • Can you just clarify which OS you're doing this on, win7 or windows server 2k8? Commented Jun 1, 2012 at 8:29
  • Just added them to the list.
    – amaters
    Commented Jun 1, 2012 at 8:42


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.