So I just switched to a new VPS and have had some issues. I have setup a basic LAMP stack on Centos 6.2. I'm a programmer, but have a decent amount of knowledge in service administration since I work for a very small company and have to do a little bit of everything. I've setup many LAMP servers without any issues.

On this server, ever since I set it up the page load speeds have been ridiculous. On a basic Drupal 7 installation, page load times range from 10 sec to 60+ sec. As I was trying to get some work done earlier, the website just stopped loading altogether. I can't even access it via the IP address. But what's strange is that I can SSH into it via my domain name just fine. I'm stumped as to what could be the cause of this.

I tried restarting apache and mysql and both restarted without any issues. I'm guessing it's something on my hosts end, but if it's an issue on my end I'd rather not wait around for them to answer my ticket as I have work I need to get done. What could cause my server to all of a sudden only be accessible via SSH? I've tried to give as much information as possible, but please let me know if there's anything else you might need.

  • This question has nothing to do with programming - voting to move
    – Adrian Cornish
    Feb 20 '12 at 0:20
  • It has as little to do with Webmastering as it has with Programming, @Adrian.
    – Pekka
    Feb 20 '12 at 20:22
  • It has everything to do with Webmastering. It ended up being a problem with my hosts network, which they have fixed now. Thank you everyone for your help! Feb 21 '12 at 12:44

Could be a memory issue and SSH or an issue with your Apache?

SSH'ing in could tell you a lot. SSH into the server, ps aux | grep apache (to even see if it's running. Type top to see what's consuming the most resources.

Also paragraphs are your friend. :)

  • Sorry, I edited my post to add some paragraphs to make it easier to read. I did top and it only shows that one COMMAND is using resources, and that is init which is only using 0.0% of CPS and 0.4% of memory.
    – Kyle Piontek
    Feb 20 '12 at 0:48

Make a request,check the time, then look at the access log on the server and see when it shows up there. That will tell you which end the delay is.

If its the client, check IPv6, check DNS - those are the usual culprits for timeouts.

If its the server, check the system and http error logs.


Even before checking delays, I would see if there's any response on your HTTP / HTTPS ports.

So from your local machine, check this by

$ telnet your_remote_vps.com 80

or whatever the listen port is. If you see a prompt, then that's likely your apache socket listening on the other end and then your hosting company is probably not responsible.

  • telnet won't give an 'HTTP Prompt.' You'd have to enter GET / HTTP/1.1 and then return twice to see it it was getting anything.
    – Daniel Lockard
    Feb 20 '12 at 0:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.