0

I have used jekyllbootstrap to setup my blog at primux.in about 2 weeks ago. The blog has been hosted at github pages at primalpop.github.com. Following the advice from here I have created a CNAME file and pushed it to repository and also added the relevant CNAME records pointing to 207.97.227.245.

Now the problem is that, sometimes the website doesn't load at all from github pages. Most of the times, it loads the index page but every other url is broken. This has been the problem for some time. I initially thought it would take some time for DNS to propagate but it's been nearly 2 weeks now and still most of the urls doesn't work on the website. It has been frustrating to say the least when someone who reads the blog, comes back and say that the link is broken.

Any help would be much appreciated.

3

You have forgotten to set your custom domain value at production_url (see _config.yml).

  • After setting the production_url to primux.in, it is showing github pages doesn't exist error. – Primal Pappachan Feb 21 '12 at 8:14
  • your CNAME file is wrong. delete http:// – julionc Feb 21 '12 at 16:06
  • Thanks, fixed it. Still primux.in doesn't load from github. :( – Primal Pappachan Feb 23 '12 at 5:46
  • I'm thinking of moving it to custom server. – Primal Pappachan Feb 23 '12 at 5:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.