When I try to link my Wordpress blog to Facebook, the url doesn't resolve properly. There's garbage appended at the end and Facebook is not able to retrieve information from the site. Happens in every page, post or main entry.

Here's what happens:

http://clarissarezende.com.br/ shows up in Facebook as http://clarissarezende.com.br/UPLcS/ (when copy/paste the link)

and no information about the site shows up in FB.

I'm using Wordpress 3.3.1 with ProPhoto 4.

Recently I moved the DNS entry on my ISP. The blog is hosted at clarissarezende.com.br/public_html/blog2 and before the DNS would point to public_html and then I changed it to public_html/blog2. Note that I did not move any Wordpress files.

Made the (I think) necessary changes all over Facebook, but still no dice...

Any ideas on what can be happening?

  • Check this: webconfs.com/http-header-check.php
    – Eight Days of Malaise
    Commented Jan 23, 2012 at 1:16
  • Yep, something wrong: HTTP/1.1 302 Found => Connection => close Pragma => no-cache cache-control => no-cache Location => /MfmgN/ But how do I fix it? Not big on web server configuration..
    – Joao
    Commented Jan 23, 2012 at 3:16
  • Looks like it's a web server configuration issue or lack of .htaccess file (tried placing one per Wordpress instructions, but no luck). I only have one plugin installed (DB Backup) and tried disabling but same thing happened, so it's not that. What should I look into? Tried several things and none worked.
    – Joao
    Commented Jan 23, 2012 at 3:40
  • Odd... using webconfs.com and perfect-optimization.com, there are 302 redirects. But my browser only seems to receive 200 OK responses. Seems like there might be some kind of cloaking going on, but I can't tell what the purpose would be. Commented Jan 23, 2012 at 11:28
  • 1
    Does the redirect issue occur with URL's which are not passed through to WordPress? Given that you don't know where the behavior originates, I would suspect that WordPress has been compromised.
    – danlefree
    Commented Jan 23, 2012 at 23:26

2 Answers 2


The support folks for the Wordpress theme I'm using (ProPhotoBlogs) gave me a hint that worked:

There's a feature that prevents images from being copied/saved/dragged in the browser. They said for me to turn it off, which I did and then the links started working again. That feature must have been the culprit.

Curiously, when I turned that feature back on, everything still worked. So I'm guessing it's when I moved the site with it ON that was the problem. Turning it off and then on again must have reset something.. wish I had more information, but it's working now.


On the bright side when you actually post the link to facebook it resolves back to the correct location.

Exactly how did you change your DNS - what code did you use to do it and do you have any functionality in your htaccess file? Your header results in:-

HTTP/1.1 302 Found => 
Connection => close
Pragma => no-cache
cache-control => no-cache
Location => /OTeaT/

And 302 is a type of redirect, and that would seem to be the source of the problem. What's interesting is the characters in the location field change on each load, sometimes disappearing entirely.

Have a look at this article http://en.wikipedia.org/wiki/HTTP_location which explains the meaning of the last field. It has to be a problem with the way the DNS or htaccess was changed.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.