3

I've created a sub domain on my website using cPanel at test.mydomain.com, and this created a folder in my main 'www' directory called test.

In this folder is a folder called cgi-bin, and it seems to redirect the page to say "It works!", but when I upload my own index.html file to the test directory it keeps showing http://test.mydomain.com/cgi-sys/defaultwebpage.cgi instead of the index file. If I go to www.test.mydomain.com then it works OK.

How do I host my content at the sub domain? It's my first time setting one up so I'm a bit lost.

1

Check in a different browser, you may be viewing a cached version of the default page. If that's the case clear your cache and refresh a few times in your regular browser. The server should be setup to accept index.html index.htm index.php and other common index pages.

0

In the test directory, ensure there's no redirect under .htaccess or an index file.

For example, in the root of my webdir my index.html was this:

<html><head><META HTTP-EQUIV="refresh" CONTENT="0;URL=/cgi-sys/defaultwebpage.cgi"></head><body></body></html>

So removing that would fix it for me.

Not the answer you're looking for? Browse other questions tagged or ask your own question.