I am having trouble with pleskrestore on Plesk 10.4.1, CentOS 5.

I have 6 files I created (also in Plesk 10.4.1) with pleskbackup, split into 4GB:

Here is what I used ...

$ /usr/local/psa/bin/pleskbackup --server --output file=ftp://user:[email protected]/colossus729_split_0 --split=4G

... to make these files:


But plesk restore wouldn’t work with those files (contrary to the documentation)

# /usr/local/psa/bin/pleskrestore --restore colossus729_split -level server -license

and get this error:

"The file you are trying to upload is not a valid backup file"

2 Answers 2


So tried to do all this with the documentation, but it is lacking in detail and accuracy. Plus, all the error messages their applications return are worthless.

Oh, and I have to say that this is the last time I embark on a project with Plesk.

Instead, my support folks had to unpack (untar?) the files so I could access this XML file.


This information is not included ANYWHERE in the Plesk documentation FYI.

But I still got errors

# /usr/local/psa/bin/pleskrestore --restore backup_info_1112070810.xml -level server -license -map map_file

Backup file has wrong format
Dump has critical errors.

Then I had to create a map file (even though Plesk’s documentation implies it is only required for Plesk 8.6 and 9 (Linux): http://kb.parallels.com/6164

# /usr/local/psa/bin/pleskrestore --create-map backup_info_1112070810.xml -map map_file

But I still got errors. Starting to see a trend.

Upon validating the file I realized it had errors so I had to manually add 2 other IP addresses to Plesk

# /usr/local/psa/bin/pleskrestore --validate-map map_file

Did it like this:


Then the map file validated:

# /usr/local/psa/bin/pleskrestore --validate-map map_file

But still got the same error message when I tried to restore

# /usr/local/psa/bin/pleskrestore --restore backup_info_1112070810.xml -level server -license -map map_file

Backup file has wrong format
Dump has critical errors.

Finding this post: http://forum.parallels.com/showthread.php?t=109694 I decided to attempt to upgrade Plesk from 10.2 to 10.3.1, then to 10.4.4 ( I originally had 10.4.1).

After that was complete I ran this and everything restored. It took at least 10 hours for 150 domains and 24GBs

# /usr/local/psa/bin/pleskrestore --restore backup_info_1112070810.xml -level server -license -map map_file

Finally, after all the clients and domains and data showed up I realized that I still had the following problems, thanks again to Plesk:

  1. Unlike the previous install of Plesk, which had PHP 5.3, this restore defaulted to 5.1, which caused many a site to break. Fixed by installing PHP53 (using official Plesk source) and the autoinstaller

    $ /usr/local/psa/admin/sbin/autoinstaller

  2. I had made fixes to my previous php.ini file. Plesk did not restore. Namely the problem with timezone support. Fixed by adding the following and restarting httpd.

    date.timezone = "America/New_York"

  3. Could not access Plesk after restore, kept getting 404s. Solved by disabling SSO.

  4. All service plans were set to defaults. Annoying.

  5. Last but not least by a long shot (at least for now). When I restored domains I found they had been given the wrong owner. User’s files were owned by the wrong user. Terrible, Plesk, really terrible. Had to do recursive chown within httpdocs to give files the right owners.

    $ chown -R user:group *


To upack / Untar:

cat "backupfilename" "backupfilename"1 "backupfilename"2 "backupfilename"3  | tar xzpv

All I had to do after that for a full server restore was:

/usr/local/psa/bin/pleskrestore --restore "backupfilename".xml -level server
  • Thanks for your answer. I have no way to test this unfortunately, as I've abandoned Plesk for good.
    – ow3n
    Jun 20, 2013 at 23:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.