I'm working with a website running Joomla 1.5. Right now I'm trying to update some articles and just recently when I tried to upload an image file (via the JCE editor extension) this error message came up:

"No Cache Directory sepcified. The cache directory specified in the parameters does not exist and could not be created, or is not writeable. Please create this directory manually or make it writeable. Until then, thumbnails, resizing and rotaing are disabled."

Now the whole page the article is on seems to not load a bunch of the images and other style information it contains. It's mostly text on a white background.

Please help me find out how to solve this, I think it's a problem with JCE but I have no idea where this Cache Directory is supposed to be found, or where I can change the parameters (already checked in backend and can't find anything).

  • If anyone would like, please go to the website: vetlandabc.com/web and click on any of the article links in the menu to the right. Then refresh that page a few times. Just so I can rule out that this isn't a problem only I am having.
    – gburning
    Nov 2, 2011 at 0:16

2 Answers 2


Well, first of all go into your administration panel and then "Help" -> "System Info" -> "Folder permission" and check if "Cache folder" is writeable or not. If it's not, change the permission of the folder using FTP or chmod command. Besides, check if that folder exist or you mispelled its name when you set up the website.

  • Thanks, I just had a look. "Unfortunately", all the folders listen under "Folder permissions" are already writeable. And I could find two cache folders, yes, but I'm pretty sure that the problem is with the JCE Editor, not our Joomla installation in general. Update: Tried to change editor, no help there. Maybe the problem is with the media files in general?
    – gburning
    Nov 2, 2011 at 0:12
  • @burnso Do you get the same error using TinyMCE? Nov 2, 2011 at 0:15
  • Yes, I do. I just tried setting up a new article using only the TinyMCE editor - it didn't make it any better unfortunately.
    – gburning
    Nov 2, 2011 at 22:06
  • @burnso This should prove that is not a JCE problem. Nov 2, 2011 at 22:07
  • Well, kind of. The truth is that I'm not getting the error with TinyMCE, but that simply seems to be because I only get it with JCE when I try to add an image through that editor. The question is though: what different kinds of cache folders are there, where should I check? How? I need to start ruling some of them out...
    – gburning
    Nov 2, 2011 at 23:14

Problem has been resolved. The error dialog still appears in the backend, but the actual problem (on the frontend) is resolved (AKA the site now loads and shows as it is supposed to - images and all). It seems that for some reason the problem was with SEO-friendly URL's (edit me if that's not the correct name). Seems like that function often causes a lot of problems at least with our site. Anyone know if it works better in newer versions of Joomla (beyond 1.5)?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.