I've got a virtual server running Ubuntu which I recently set up. As I was trying to learn how to deal with vhosts and serveraliases I made a few errors before I finally managed to get the vhost files in sites-enabled and sites-available working. I kept testing my websites in Firefox (and Chrome I guess) during my various vhost tryout debacles and now when I got everything right I can't reach one of the sites from Firefox and Chrome but in Safari everything seems ok.

It's working fine in all browsers if I'm not putting "www" in front of the domain name, the problem only appears when typing "www.example.com" in the address field instead of just "example.com". Also, "dig www.example.com" displays the correct IP.

I've tried to clear DNS caches in Firefox and Chrome but with no luck, here's what I did in Firefox: http://www.kahunaburger.com/2009/03/18/clear-dns-cache-in-firefox/ And for Chrome I found "chrome://net-internals/#dns" and clicked the clear DNS button.

I also tried to clear my client computer's (Macbook Air running Snow Leopard) DNS cache by running: "sudo dscacheutil -flushcache" No luck.

If anyone has any suggestions whatsoever please reply, thanks!

closed as too localized by danlefree Apr 17 '12 at 18:21

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center. If this question can be reworded to fit the rules in the help center, please edit the question.

  • 2
    Is there a chance you can post the part of those vhost files regarding to the domain with problem? this could also be happening if you didn't put a * infront of your domain – Shedokan Oct 31 '11 at 21:04
  • Thanks for your reply! Ok, now it's finally working in Chrome! But still not in Firefox, it's been like this for a week so I don't think there's some TTL's that haven't expired. I think the "chrome://net-internals/#dns"-thing started working after I restarted Chrome. The vhosts are fine and the domains are pointing to the right place etc, trust me - that's not the problem. It works for everyone else and in any other browser other than Firefox on my Macbook Air. – Richard B Oct 31 '11 at 21:14
  • I suggest trying superuser.com/questions/297023/… and linked questions – Shedokan Nov 1 '11 at 1:08
  • Did it answer your question? because if it is I'll vote it as duplicate – Shedokan Nov 7 '11 at 22:18
  • 1
    Which versions? I've run into some problems recently with the latest versions of Firefox and IE concerning embedded fonts and cross domain access prevention. – toomanyairmiles Jan 16 '12 at 22:53

Browse other questions tagged or ask your own question.