I have adsense for content set up for my site running on my blog.

It shows up below the post content on each single post (like this one): http://engineercreativity.com/blog/learning-xhtml-and-css-day-12-of-30/

However, instead of this showing up:

Ads by Google Ad1 Ad2 Ad3 ...


Ads by Google View ads about: [textbox] [button]

Does anyone please have any idea on how to fix this?



  • 1
    I currently see Google Analytics, but no code for Google ads?
    – Tim Post
    Aug 10, 2010 at 13:30
  • I also cannot see anything on that link. Is it on another page or have you removed the Ads entirely @Amit? Aug 10, 2010 at 15:06
  • Ah man, yeah I've removed the code entirely. I'll put it back in there just so you guys can see what I'm talking about. It should be back there. Sorry about the confusion
    – Amit
    Aug 10, 2010 at 19:21

2 Answers 2


That is bizarre, I've never seen anything like that before. First, you should go back and check the code to make sure the code that is output on your page is exactly the same as the code generated from the adsense Ad Manager section.

If you edited the code yourself, such as changing the size, there may be a conflict between the settings in the Ad Manager and what you're telling the ads to display. The code may change if you're using a "helpful" WYSIWYG editor in a CMS, for example, so check against your browser's "view source" function.

Make sure you are using the right settings, i.e. Adsense for Content, Link Unit, and the right size from the drop down (468x15 in your case).

  • Yes. I've verified the code various times and it's identical. It's a copy/paste to what Google gave me... I SHOULD MENTION that my PIN is not yet verified, so it's telling me that only PSA (public service ads) are shown. Might this be a problem?
    – Amit
    Aug 11, 2010 at 17:29

This occurs when Google can't figure out what kind of ads are relevant to your blog. Either because the content is too new, or too controversial, or general glitchiness.

More info about this.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.