0

I have a Google+ Share button for each article on my website.

At the moment, when I try to use it, Google+ uses an unrelated image in my document (probably the first one in the document above a certain size) as the thumbnail shown in the feed.

I'd like to specify a thumbnail url to use instead. I used the +1 button tool to generate the proper meta tags, but it just doesn't work. It's still using that unrelated image.

Anyone got it working?

3
  • Did you modify your html element as it says down the bottom of the page? Do you want to give us a link to where you've put it so we can check it? Sep 28 '11 at 13:20
  • Yes, I did! Example article: indievault.it/2011/09/28/…
    – pt2ph8
    Sep 28 '11 at 13:24
  • By the way, one thing to note is that the thumbnail is not included in the article's page as an img tag. The thumbnail for that article I linked should be this one (as shown in the homepage) indievault.it/wp-content/uploads/thumbs/2011/09/… I don't think this should be a problem, but I'm saying it just to make sure.
    – pt2ph8
    Sep 28 '11 at 13:25
1

The reason that your specified thumbnail image is not being picked up is because Google+ doesn't like small images (<170px width).

If you link to the full-size image instead of the thumbnail and let G+ do the resizing it will work. I've tested your code with a larger image from your site and it seems to work.

Reference:

0
0

Write an IMG tag with the right thumb at the beginning of the body and make the the css to display:none

Don't forget that the article thumb may be cached already so it will work only for further articles and/or after cache expiration.

10
  • Tried that too. If you check the HTML in the page I linked in an earlier comment you'll see an img tag with the thumbnail URL and display:none. Not working :( Even tried to add itemprop="image" to it, but still not working. It's not the cache either, as I tested it with old (2010) articles.
    – pt2ph8
    Sep 28 '11 at 13:35
  • 1
    Found this : The reason that the +1 Button is not pulling the image marked with the itemprop is because your image resides outside of your itemscope element. If you specify an image inside your article, the +1 Button will pick it up. SOURCE Jenny Murphy, Google employee : link
    – jflaflamme
    Sep 28 '11 at 13:48
  • Thanks a lot, but what does "inside your article" mean? Do I have to add an attribute to the article's div or something, and then add the itemprop inside this div?
    – pt2ph8
    Sep 28 '11 at 13:49
  • Explanations here
    – jflaflamme
    Sep 28 '11 at 13:54
  • I tried that, but still nothing (added itemscope itemtype="http://schema.org/Article" to the body tag and then the image with itemprop="image")
    – pt2ph8
    Sep 28 '11 at 14:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.