I am trying to implement Google Apps for a new domain of mine, and although Google says it can take up to 48 hours, it is normally much quicker than that, and other DNS changes, such as creating the domain alias, normally take less than 1 hour to propogate. The domain I'm trying to set up Google Apps for is an alias of an existing domain - let me explain:

I have mainDomain.com, and this is the name of my domain account on my host, which I cannot change. However, that domain name has expired and is no longer available, so I create a domain alias on the host called aliasDomain.co.za, and choose not to use the main domain DNS. I then set all the MX records, as documented by Google, on aliasDomain.co.za, but it's been about 12 hours with no joy yet.

I suppose I should wait the 48 hours, but if my DNS is wrong, it could be another 48 hours to see if I did fix it. Should what I'm doing work normally, or should I be doing something else?

  • belongs on webapps.SE
    – BBlake
    Jul 28, 2011 at 17:48
  • You should have planned ahead and reduced the TTL beforehand, so that the new settings get propagated quicker.
    – paradroid
    Jul 28, 2011 at 17:49
  • @paradroid, I literally have several days to do this, but that is not my issue. My issue is that all my other changes today and last night were live within 30 minutes, while the most recent MX changes, made around 12pm, still haven't propagated.
    – ProfK
    Jul 28, 2011 at 19:40
  • @BBlake, thanks for the migrate. It never occurred to me that this was more than a 'power user' issue because it's just a little personal issue, so it seemed local enough for SuperUser at the time, and I didn't give it more thought.
    – ProfK
    Jul 28, 2011 at 20:05

1 Answer 1


I have resolved this matter, here are the details:

When I created the domain alias on my host's control panel, I removed all existing CNAME and MX records, leaving only the NS and A records. Then I followed Google's instructions for setting up new MX records. This worked, but I was under the impression it didn't work, because the URL mail.aliasDomain.co.za still pointed to my host, not to Google. I suspected I was missing a CNAME, but when I tried to create a new CNAME pointing mail.aliasDomain.co.za to ghs.google.com, I got an error that such CNAME 'already exists for the zone'.

It turns out that I created all the MX records with the mail prefix, so I couldn't create another record to that same name. After removing the mail prefix from my MX records, I was finally able to create one required CNAME, to gsh.google.com, for the mail prefixed zone.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.