3

At stage 3 of the Prestashop Installation, I enter the DB details which I know to be correct, and I receive the error:

Database server was not found. Please verify the login, password, and database server name fields.

The server is localhost, and I have verified the database name and username. Why can Prestashop not find the server?

This occurs when choosing InnoDB and MyIsam.

If I change the server from localhost to the public hostname I receive the same error.

  • 1
    1) Double check that you can actually login into DB using those details (you may have correct login/database in place, but, probably, username was set up in such way that it not allowed to connect from that address); 2) Please check if you can connect to that DB from within PHP (create some simple test PHP script) -- maybe you do not have required extensions enabled; 3) Firewall? (don't think so .. but); 4) Server address: try 127.0.0.1 instead of localhost.. or you may need to specify some another name (linux socket?) -- consult your hoster for exact details – LazyOne Jul 10 '11 at 10:40
2

Be careful about the collation settings of the database you created. Collation must be utf8_general_ci for database Prestashop. Otherwise you receive connection error.

| improve this answer | |
1

I recreated a 2nd user account, which tested okay.

| improve this answer | |
1

Despite WAMP supposedly using root/root as the default, the MySQL uses root/[no password]. Silly Prestashop error about database server is not found, is actually just a logon problem.

| improve this answer | |
1
  • First create new db in phpmyadmin.
  • For the user, keep it root.
  • Just leave password as blank. You can change it later once successfully installed.
  • Click on "test db"

This is what worked for me.

| improve this answer | |
1

This problem occurs because I use Prestashop with Docker.

Using the container name as the host solves this problem.

| improve this answer | |
  • Although this problem has passed for a long time, this problem still exists.Hope it will be useful for future friends. – jerry xu May 2 at 7:42
0

Go to the members' area, enter the control panel and click on the 'MySQL' icon. Your MySQL hostname / username / database name etc will be listed there.

Also make sure you use the correct hostname, not localhost.

| improve this answer | |
  • The OP has already stated that the correct hostname is localhost and that the problem was related to the user and not the database connection. – MrWhite Nov 7 '12 at 8:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.