I'm having a very frustrating problem with my Joomla 1.6 site. I cannot add any new extensions through the admin interface. I have tried to upload the extension, or to use the search folder option or even the direct link. Neither of these options work, and all that happens is that the page tries to load forever until it finally timesout with a blank white page (no further error messages).

I have tried this with multiple browsers (Chrome,FF,IE) and I have tried it with different extensions (modules, components, templates - all the same result). So I don't think it has anything to do with what I am uploading, but more likely the problem is something with the post action. I have also seen the exact same error occur when I try to update menu items or even create new menu items.

I am not getting this error with a duplicate of the site in the dev environment, but only get this on my shared web hosting live server. This is on a Windows IIS / PHP / mySQL environment.

  • in the administrator CP, go to: Global Configuration -> system and turn on "Debug System".
    – Nir Alfasi
    Commented Feb 27, 2012 at 9:09

2 Answers 2


I have ran into a similar problem, Joomla post issues can be critical sometimes but your best bet should be to unzip the packages and upload via FTP. also have you discuss this issue with your hosting provider? what kind of permissions do you have?


If it is a problem with uploading it can be a number of issues including PHP. Have you considered upgrading to 1.7?

Also, check your error logs for problems, chances are if Joomla! cannot upload then something else will have the same issues and it is worth checking out.

What is the exact error you get anyway?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.