0

When testing my webapp manually I get a confirm box: http://dl.dropbox.com/u/1342388/syneto/good_conf_box_1.png http://dl.dropbox.com/u/1342388/syneto/good_conf_box_1.png, the browser renders it with an overlay, but when run with remotewebdriver the overlay is not present and the confirm is in a window http://dl.dropbox.com/u/1342388/syneto/bad_conf_box_1.png http://dl.dropbox.com/u/1342388/syneto/bad_conf_box_1.png, any idea why is this happening?

Same browser, FF4. The remotewebdriver sends an instantiated FirefoxProfile without modifications that adds this user.js to the Firefox Profile.

1

Try adding this line to the bottom of the user.js profile to force modal prompts:

user_pref("prompts.tab_modal.enabled", true);

One of the lines in user.js is likely resetting the default behaviour for Firefox 4 prompts, so adding that line at the end of user.js should override the reset and force the new prompt style.

| improve this answer | |
0

WebDriver deliberately sets prompts.tab_modal.enabled to false to be able to deal with alerts across Firefox versions. You can't override the setting at the moment.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy