1

When I first published and submitted/indexed my site, I didn't have any html tags. I realized that quickly and fixed the problem. I've resubmitted my site with the proper seo stuff, but it's not being updated in the google serp results.

Google SERP result

Even though I think my HTML contains the proper seo information:

<!DOCTYPE html>
<html lang="en" class="scroll-smooth">
  <head>
    <meta charset="UTF-8" />
    <meta http-equiv="X-UA-Compatible" content="IE=edge" />
    <meta name="viewport" content="width=device-width, initial-scale=1.0" />
    <title>Blog to Doc</title>
    <meta name="description" content="One-click convert any online blog to docx for free">
    <meta name="og:title" property="og:title" content="Blog To Doc">

It's been a few weeks, and the SERP still hasn't been updated. I'm wondering if I'm doing something wrong.

2 Answers 2

1

Their cached copy is the latest, so it is not a crawling or indexing issue.

Google do re-write the title and description if they think they can generate a better one elsewhere.

Indeed, their documentation almost makes it sound like their secondary choice:

Google will sometimes use the <meta name="description"> tag from a page to generate a snippet in search results, if we think it gives users a more accurate description than would be possible purely from the on-page content

It's worth reading the above page for Google's advice, but my thoughts would be that your own description is way too short for them to choose it. It should be about 150 characters.

2
  • Interesting. I'll try to revise the meta description. But what about the "blogtodoc.com" above the small URL? I don't think that's what it's supposed to be. I have the <title> tag, but it's not applying to that.
    – No Name
    Commented May 4 at 6:03
  • 1
    That's what Google thinks is the site name, not the page title. The more signals you provide, the more likely it is to choose the one you want. Try adding some structured data for starters - developers.google.com/search/docs/appearance/site-names
    – RichardB
    Commented May 4 at 15:30
1

Your website is accessible over both HTTP and HTTPS, which violates Google's website quality guidelines.

enter image description here

At the same time, the pages have different text content. This looks like search engine manipulation and can affect the speed at which Googlebot indexes pages.

HTTPS enter image description here

non HTPPS enter image description here

3
  • There are actually two things going on. First, I'm not sure why both the http and https versions show up in a google search. If you go to either one of them, it redirects you to the HTTPS version. The different text content has nothing to do with http. It's because of having the www or not. The pythonanywhere version does NOT have www. I'm not sure how to fix either one of those issues.
    – No Name
    Commented May 5 at 22:54
  • this is really strange. When you go to the search results, the redirect is processed. however, if you enter the address of your site into the address bar of your browser using the http protocol, the redirect will not work. Commented May 7 at 11:25
  • try setting up redirection using the web server (Apache or Nginx). Commented May 7 at 11:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.