0

I've been asked to resolve a problem for a web application working in tandem with a desktop app. I can't recode the apps, I can only configure the IIS server to do what the business unit wants. The desktop app can only use a "relative path" using a mapped drive letter. The web app has no idea what to do with the mapped drive, it wants a UNC path.

The app pool identity is an AD account with elevated rights, and when I sign into the server as that account, I can see and access the mapped drive. If I go directly to the resource that is mapped, I have access to everything I need. I just don't know how to make that mapped drive visible as a server instead of a local drive.

Would creating a DNS named space work for this? Is there an IIS setting I'm overlooking? Any direction would be appreciated.

4
  • Sorry, it's been years since I ran IIS servers so I'm probably not totally understanding the problem. However, do these help: stackoverflow.com/questions/57148733/… and serverfault.com/questions/279414/…
    – Trebor
    Mar 31 at 0:15
  • It might. I stumbled on the load user profile option on another site after submitting this, now waiting for the user to confirm that the app works when that setting is enabled. Don't know why I forgot about this setting except that I rarely ask my server to operate this way. Thanks for the response, fingers crossed! Apr 1 at 13:25
  • Just heard back that the app pool already had that set to True, and even after an IIS reset the problem persists. Apr 1 at 14:24
  • I'm going to suggest we move this post to StackOverflow. I think you'll find more people there familiar with IIS and the app pool properties.
    – Trebor
    Apr 2 at 14:46

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.