1

My site is having issues with Googlebot queries (ridiculous numbers of them that are bogging down the server); I'm not sure if that is related to this...

My Google Search Console shows a MASSIVE increase in "non-indexed pages" over the past 30 days or so... from 5k "not indexed" to 331k "not indexed." It shows 1.5k as indexed, which is about the actual number of URLs on my website.

I'm showing a LOT of error URLs that are just bizarre, like this one:

https://www.naturalbirthandbabycare.com/birth-plans-dont-work-write-one/?kuid=78b1377d-9086-46c6-9ab0-df56eaf7fd8b&kref=https%3A%2F%2Fwww.naturalbirthandbabycare.com%2Fmichelle-baby%2F

I don't understand where a URL like these even comes from, or what the ?kuid is... and the second URL isn't even linked from the root URL.

I'm not sure if there's a plugin or something that started this, or what I should look for to correct this. I'm also showing a ridiculous amount of redirects, including "redirects" from pages that are not redirected at all - like my About Me page (I'm talking over 100k "redirects"). The "redirects" also show bizarre URL strings like the above. Another example:

https://www.naturalbirthandbabycare.com/pregnancy-coach/?kuid=b1badcda-9ecf-4ff1-b18b-bd6ba1aa372c&kref=https%3A%2F%2Fwww.naturalbirthandbabycare.com%2Fmissy-baby%2F

Any help is appreciated.

4
  • 1
    It is other sites linking to yours, with no good intent. Feb 7 at 23:52
  • Is there anything I can do about that?
    – skrimpy
    Feb 8 at 1:05
  • 2
    You can set a canonical header so that example.com/my-article?xyz=123 is known as example.com/my-article. You could also try to redirect (301) those variations to your base page. Feb 9 at 16:11
  • A partial answer on the origin of ?kuid and ?kref would be "key user ID" and "Key referrer". OP @skrimpy, do you by any chance use Kartra along with your wordpress site? (I have this issue too, and found your question while googling for solutions)
    – Lee
    May 1 at 14:56

1 Answer 1

2

You can block these URLs in your robots.txt file to prevent crawling. I suggest you modify your robots.txt file like this to exclude all URLs with the two parameters from your example URLs:

User-agent: *
Disallow: /*?kuid=
Disallow: /*&kuid=
Disallow: /*?kref=
Disallow: /*&kref=

Note: there are two rules for each parameter so the parameters would also be blocked when they are in different order.

In addition you should inspect those URLs in Google Search Console and check what URLs are listed as referring pages, as this could also be generated by some kind of plugin.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.