1

I followed the instructions by Tony Teaches Tech (page, video) to set up a WordPress site hosted on Google Cloud VM.

I am now trying to install the "Really Simple SSL" plug-in, but get this error:

The PHP function CURL is not available on your server, which is required. Please contact your hosting provider.

As per an answer by the plug-in author here, I've tried following these instructions: "How to Install php-curl in Ubuntu ?"

It seems like I now have it installed:

enter image description here

Unfortunately, I still get the same error:

enter image description here

(I also get the same error when trying to install other SSL plug-ins on WordPress.)

Any idea how I can fix this?

(I'm a complete idiot on this and only got this far by carefully copy-pasting instructions given by others. Please let me know what exact commands I should copy-paste and where. Thanks!)

4
  • The function may be disabled in the PHP settings for security reasons. In that case you need to edit the php.ini to remove the function name from the list of disabled functions.
    – Thomas
    Commented Jan 15 at 10:17
  • "only got this far by carefully copy-pasting instructions" - perhaps you should consider learning on a machine which is not exposed on the internet. That article on installing php-curl is wrong in some regards - notably you need to restart the php-fpm server, not the webserver for this configuration.
    – symcbean
    Commented Jan 15 at 12:35
  • What does this return sudo -u www-data curl --version ? Commented Jan 16 at 21:51
  • ....nothing relevant since the php curl functions do not use the cli curl tool.
    – symcbean
    Commented Jan 17 at 14:19

1 Answer 1

1

It should be php-curl instead of curl:

sudo apt-get install php-curl
1
  • 1
    The above fixed this particular error. But then of course a different error occurred. A much better and simpler option for SSL (for dummies like me at least) is certbot.eff.org
    – user182601
    Commented Jan 17 at 23:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.