I have a domain and its DNS mappings on Namecheap. I have had *(wildcard) subdomains mapped using an A record to IP of my EC2 instance on AWS. It worked fine. No issues at all. All subdomains like abc.domain.com resolve correctly and I can access them in any browser(Chrome/Edge/Firefox).

Yesterday, I changed it to CNAME and mapped it to the name of my Load Balancer on AWS, something like: abc-elb-7383322339.ap-south-1.elb.amazonaws.com

Now, when I access the subdomains on my Windows 10 PC, on Edge pretty much none of them resolves and I get: DNS_PROBE_FINISHED_NXDOMAIN. On Firefox, some work, some don't. On Chrome, they mostly work but occasionally some don't but they soon load. I changed DNS servers on Windows PC to and as well. Same result. Though on my android phone, both Chrome and Edge work fine for all subdomains.

It's not DNS propagation delay - since the requests are not going to my earlier IP. The name doesn't get resolved at all.

Searching online, I find some people saying that there are issues when CNAME is used with wildcard but nothing definitive.

So should I just stick to A record for wildcard?


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.