0

Source: ^help-msa.publictalksoftware.co.uk/(.*)

Target: https://www.publictalksoftware.co.uk/help-msa/$1

For example:

https://help-msa.publictalksoftware.co.uk/msa-overview.html

should redirect to:

https://www.publictalksoftware.co.uk/help-msa/msa-overview.html

But it fails.


Initially I tried using the WordPress Redirection plugin. But now I am trying my .htaccess. I tried:

<IfModule mod_rewrite.c>
    RewriteEngine on
    RewriteCond %{HTTP_HOST} ^help-msa\.publictalksoftware\.co.\uk
    RewriteRule ^(.*)$ https://www\.publictalksoftware\.co\.uk/help-msa/$1 [L]
</IfModule>

But it blows up the website. I know it is a Linux computer (the server).

4
  • @StephenOstermiller I tried using curl. It says "Server: nginx/1.21.6". Commented Oct 23, 2023 at 19:21
  • nginx doesn't support .htaccess. You'll need to edit your nginx configuration. Is this the WordPress plugin you are using? wordpress.org/plugins/redirection It says that it can export an nginx config file for you. I would assume you have to install it manually though. Commented Oct 23, 2023 at 19:23
  • Then either nginx is in front of Apache as a reverse proxy, or Apache is configured to pretend to be nginx. Commented Oct 23, 2023 at 19:27
  • @StephenOstermiller Actually, I think the htaccess redirects are replicated in the wordpress stored redirects. So I guess it was not using htaccess like you said. Commented Oct 23, 2023 at 19:28

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.