I upgraded from WordPress 4.9.6 to 6.3 and initially everything seemed fine.

I installed the latest version of the X theme (by Themeco) with no issue.

But when I applied my old X child theme the site has crashed. The admin panel will not load, even Recovery Mode doesn't work.

I have subsequently removed all plugins and themes (except for twentytwentythree).

Nevertheless, I keep getting variations of this error in my Apache logs:

mod_fcgid: stderr: PHP Fatal error: Allowed memory size of 1073741824 bytes exhausted (tried to allocate 4096 bytes)

Out of desperation I have successfully increased the amount of memory available to 256M, then 512M and finally 1024M.

But no matter how much memory I allocate, the "tried to allocate" amount is always tiny: either 4096, 8192, or 20480 bytes.

Added to wp-config:

define( 'WP_MEMORY_LIMIT', '1024M' );

And php.ini:

memory_limit = 1024M

I have tried different versions of PHP from 7.4.33 to 8.1.23, and switching between FastCGI and FPM.

I found this comment on StackOverflow that seems to describe my situation, but I have no idea what the next step should be.

My guess is infinite recursion tried to allocate 8192 bytes typically when this is a low value that is the reason. If you up the memory above that amount and it still happens, then that's another marker for it.

PHP 8.0.30 | WordPress 6.3 | CentOS 7.9.2009

1 Answer 1


Maybe this will help someone one day.

I turned out my theme was somehow still active, even though I had renamed its directory.

Now that I am actually running the default WP theme I can log into the admin panel.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.