0

Problem: my domain often goes nowhere when entered into a browser without the leading www. (Below, my real domain is changed to 'example')

I've had a domain on NameCheap for a while and was using their hosting and ConcreteCMS via their CPanel.

I wanted to use Format.com for the site instead, so I cancelled the NameCheap hosting (& now reinstated because I forgot I had email on NameCheap...) I setup example.format.com and in their domain setting for "Add your own domain" I've input example.com . It says "Connected" as if their verification checks out.

In NameCheap, I have:

  • A Record - mail - [an IP] - TTL=Auto
  • CNAME - www - example.com. - TTL=30 min
  • TXT - @ - v=spf1 +mx +a +ip[an IP address] ~all - TTL=1 min
  • TXT - default_domainkey - v=DKIM1; k=rsa; p=[long alpha string] - TTL=1 min
  • URL Redirect - @ - http://www.example.com/ - Permanent (301)

I presume only due to caching I can sometimes enter the domain without www. in my browser and it'll load. Most of the time it will not though. Tested on multiple devices. Not sure where the problem lies, and neither is Format or NameCheap. Any ideas are appreciated.

6
  • @JohnConde why the edit to only one of the URLs? The domain change could mislead the reader to thinking I'm using that one if unexplained.
    – Darrel H
    Aug 15, 2023 at 19:03
  • 2
    John changed the URL because it is against StackExchange policy to use the real domain name, so he changed it to the standard "example.com". It prevents people from just using groups like this for the sole purpose of backlinking.
    – Trebor
    Aug 15, 2023 at 19:10
  • 2
    Got it. Guess I'll try to change the other ones..
    – Darrel H
    Aug 15, 2023 at 19:56
  • What is your domain name? (So we can do llokups and see what is actually going on). It is not possible to do a URL redirect in DNS - so the URL Redirect is likely a bad construct created by melding DNS and a web server - and often don;t handle https well.
    – davidgo
    Aug 15, 2023 at 21:28
  • Importantly, if you have an A record to the MAIL IP address as above that is wrong and broken. The A record should point to the IP address which your www.example.com CNAME resolves to (ie an IP address, not a CNAME), and you should add an MX record for direction of where mail should be delivered. You may also need to add asubdomain with a mail record as the MX record points to a domain name, not IP address.
    – davidgo
    Aug 15, 2023 at 21:30

1 Answer 1

2

Looking at your domain name, it looks like you have MX records set up which is good and explains why mail is working (just for the sake of completeness, you can use an A record for mail, but really, really shouldn't. Anyway, that does not matter here as you have MX records)

The problem is the URL Redirect - you need to get rid of it, and replace it with the correct A record. I expect Namecheap have added in an A record to point to their servers and do redirection. The problem - which is not new - is that while it is easy to redirect HTTP, you can't redirect HTTPS without first handling the certificate/https issues - and this is the cause of your issue. For the sake of clarity http://(yourdomain.com) redirects to your website, but https://(yourdomain.com) does not - ie the URL redirect does not work for HTTPS. The solution is to not use a URL redirect, but add the A records for (yourdomain.com) - likely 104.18.132.62, 104.18.133.62, 104.18.134.62, 104.18.135.62 and 104.18.136.62 [ If you can't work out how to add all, add one and this should work most of the time ]

6
  • It seems, part of responsibility for such kind of issues is on NameCheap service.. Isn't it?
    – Tom Newton
    Aug 17, 2023 at 10:52
  • 1
    @TomNewton Possibly. That is out of scope here and not something I want to comment on as while I use Namecheap for some registrations I run my own nameservers and dont know what representations they make. about their value-adds. Their interfaces don't seem to be very intuitive but their helpdesk seemed competent the last time I needed it (a long time ago)
    – davidgo
    Aug 17, 2023 at 19:55
  • I had added two of the IPs you mentioned. At first last night it seemed to work. This morning I found only Cloudflare error screens though. I've tried to revert back to the redirect for now. Format.com admits/agrees that yourdomain.com without www or www. won't ever resolve. I feel like I can't be the only one with this problem.
    – Darrel H
    Aug 22, 2023 at 14:54
  • Well what do you know, once I specifically asked "can I use an A record instead of the redirect?" they immediately answered YES and gave me the IP for it! In the namecheap panel I had created a redirect under their basic settings tab, then added the 301 redirect under the advanced settings. Should I create the A record and delete BOTH redirects? Thanks @davidgo again for your help!
    – Darrel H
    Aug 22, 2023 at 17:37
  • Yes, that is what I would do.
    – davidgo
    Aug 23, 2023 at 0:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.