1

Hello recently I set up a server using Ubuntu 22.04.1 LTS and Plesk Obsidian 18.0.48. However I encountered a problem when uploading files around 1GB of size. The website I am running is a docker-compose project with Python 3.10 as codebase.

I know that this question has been asked already, but for some reason nothing seems to work for me.

What I already tried

  • I created a file /etc/nginx/conf.d/aa_client_max_body.conf with the content client_max_body_size 2048m;
  • I also tried adding client_max_body_size 2048m; to /etc/nginx/nginx.conf => http (I commented out the content of the other file to prevent misconfiguration errors)
  • I created the file /usr/local/psa/admin/conf/panel.ini with the following content
[webserver]
nginxClientMaxBodySize =
  • I added client_max_body_size 0; to Domain => my.domain => Hosting & DNS => Apache & nginx Settings => Additional nginx directives
  • I added LimitRequestBody 0 to Domain => my.domain => Hosting & DNS => Apache & nginx Settings => Additional directives for HTTP and Additional directives for HTTPS
  • I increased the values of post_max_size and upload_max_filesize under Domain => my.domain => PHP Settings both to 2048M

The website is a https subdomain.

Thanks for every help :)

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.