I want /var/www/thepowerhousemethod.org/public_html/index.html to load. Currently another page is loading instead.

/var/www/thepowerhousemethod.org/public_html/index.html is displaying in green font on the cli.

Error log shows

[Wed Dec 07 10:57:54.646257 2022] [core:info] [pid 27408] [client] AH00128: 
File does not exist: 
/var/www/thepowerhousemethod.org/public_html/files/, referer: binance.com

I don't understand why /files/ is being looked for when /var/www/thepowerhousemethod.org/public_html/ is the directory to use which matches the webserver configuration file.

    [Neptune@0rcan0mic conf.d]$ cat thepowerhousemethod.org.conf
    <VirtualHost *:80>
            ServerName thepowerhousemethod.org
            ServerAdmin webmaster@localhost
            DocumentRoot /var/www/thepowerhousemethod.org/public_html/
            ErrorLog /var/log/httpd/thepowerhousemethod.org-error.log
            CustomLog /var/log/httpd/thepowerhousemethod.org-access.log combined
        DirectoryIndex index.html
            <Directory "/var/www/thepowerhousemethod.org/public_html">
            DirectoryIndex index.html
    #       AllowOverride All
    #Options Indexes FollowSymLinks Includes ExecCGI
    #AllowOverride None
    #Allow from all
    RewriteEngine on
    RewriteCond %{SERVER_NAME} =thepowerhousemethod.org
    RewriteRule ^ https://%{SERVER_NAME}%{REQUEST_URI} [END,NE,R=permanent]

any suggestions? Self hosted bare metal server

1 Answer 1


the webserver configuration file domain.com.conf was missing

ServerAlias www.domain.com
systemctl restart httpd 

site loads!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.