2

I am setting up a company intranet (extranet) and need to block all traffic requesting to the portal besides anyone connected to our VPN.

What I've tried

I've tried adding this to /etc/apache2/httpd.conf

<Directory /var/www/portal>
    Order deny,all
    Deny all
    Allow from <ip>
</Directory>

What's happening is nothing. Not traffic is being blocked.

We are using Ubuntu as the server, and Apache2 as our webserver. We are using certbot to create the SSL cert (not sure if this helps or changes things.)

1
  • I assume you have limited the existing exceptions manually? Try adding more specific information, being that this as stated sounds technically network/security related. As in more login/handshake authentication protocols, domain/dns/cdn information, routing settings such as dynamic routing, link states, or sample configurations if you don’t get a response follow up here, id advise adding it as well if you resubmit: security.stackexchange.com
    – third3ye
    Jun 20 at 1:01

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.