1

A client that I am working for has come to me with a problem. Their Google Adwords account has been disabled because there is a bunch of traffic to crazy non-existent pages on their website. Here are some examples:

http://example.com/ffdd1g/military-decoration.html
http://example.com/ffdd1g/my-first-love-story.html
http://example.com/ffdd1g/72-x-42-shower-pan.html
http://example.com/ffdd1g/dz-diagzone-pro-apk.html
http://example.com/ffdd1g/daraz-seller-account.html
http://example.com/ffdd1g/uo-outlands-macros.html

All of this content doesn't exist. I've checked their sitemaps.xml and robots.txt to see if there was any of this content in either of those files but there wasn't. I've looked in their apache2 logs and noticed that basically the only traffic to these pages are bots. GoogleBot, BingBot, AhrefsBot and SemrushBot. Looks like Ahrefs and Semrush (two SEO companies) are big contributors to this traffic.

I'm afraid that someone before me may have used some sketchy backlink generator and caused these links to be populated all over random websites with no hopes of getting the links removed and the crawling stopped.

How do I get Google to stop indexing this traffic so that I can get my client's Google Adwords campaigns back up and running? Any ideas would be enormously helpful.

1

1 Answer 1

1

Several things you can check/do:

  1. Check that all URLs return a 404 code (check with a public validator changing user agent as Google Bot as well to be sure)
  2. Block them in robots.txt (if possible the complete directory, otherwise, mention each file)
  3. Review any referrers in your apache logs, and if found, try to contact them to remove the links. Alternatively, you can also try to Disavow the referring sites
  4. Scan your website for modified files/malware. If you are using WordPress, several plugins can help you.
  5. Conduct a full security audit of your server, patch everything and harden any potential vulnerabilities.
  6. Review server logs for any potential breaches
  7. Check inside the Google Search Console for any manual actions or security observations
  8. Ask Google to remove each one using the removal tool inside Google Search Console
1
  • Thanks, a little late but this is the correct choice. I ended up looking through the Apache logs and noticed that what was happening is the server was responding with 301 errors for bad links IF it was an http:// URL. It was returning 404 as expected for https:// URLs. What was happening is the server simply auto-redirected non-encrypted traffic to the https:// equivalent using a 301 before returning the 404. That's why Google cancelled the AdWords campaigns. So I just disabled all http:// traffic by closing port 80 on the server and it fixed everything. Good answer and thank you! Mar 24 at 18:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.