0

I've got my Wordpress website www.polandio.com which is possible to find in Google under "Polandio easy Polish news" (for example). The website is shown in Google with http protocol.

The website is always shown in https (with an active SSL) in browsers, however. I achieved this by typing "https://www.polandio.com" in Wordpress general settings, fields "Wordpress address" and "Site address".

I read that in order to make Google show the address with https it's necessary to create a 301 redirection. I don't get how Wordpress managed to show whole website in https without such a redirection, but anyway, I tried creating such a 301 redirection (in the hosting & DNS zone hosting provider admin panel) http://polandio.com -> https://polandio.com and I ended up with a "redirection loop".

My questions are...

  1. Does the current results in Google affect the position of my website in Google?
  2. How did Wordpress manage to create a redirection without creating a redirection?
  3. Why did the described redirection loop appear? I can't see anything that might get looped here.
  4. What's the simplest efficient way to make Google show my website with https, saving the Wordpress settings which make my website actually appear fully with https in browsers?
1
  • We don't allow lists of questions in a single post. Please edit to remove the extra questions and just focus on the one question that has been answered already. Other questions could be asked in separate posts. Mar 11 at 9:09

1 Answer 1

2

You don't need to have Google show http, what is important is where people end up. If you add the following code to your .htaccess file it will force people to https and solve your redirection loop.

RewriteEngine On 
RewriteCond %{HTTPS} off 
RewriteRule ^(.*)$ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]

or even easier is to install the Really Simple SSL plugin which will do that for you.

Not the answer you're looking for? Browse other questions tagged or ask your own question.