(I have a created a new container to test the stuff below as the original one is too complex with many tags for various campaigns/analytics)

So I have 3 tags

  1. a simple tag that is of type 'custom HTML" and it just runs this javascript
    <script type="text/javascript">
      alert("my-alert triggered");
  1. a GA4 tag
  2. a UA tag (I used "enable overriding settings in this tag" to input my UA ID)

The 3 tags above uses a trigger that fires using a "DOM ready" event.

preview results/observations:

  1. In tag assistant, it seems none of my tags were supposedly triggered (see screenshot link below)
  2. I got the JS alert on the website preview.
  3. for my GA4 tag, I can see this line (https://www.google-analytics.com/g/collect?v=2&tid=G-GA4-ID-HERE) when viewing browser developer tools => network tab
  4. My UA tag never showed up like in no.3. I am assuming that a similar call will be made but using my UA ID.
  5. I tried with and without "include debug signal in the URL". It does not make a difference.
  6. I tried disabling the GA4 tag. And while I cannot see no.3 in browser developer tools => network tab, I still cannot see the UA.

Any ideas what I could be doing wrong? Thanks!

links to screenshots: https://i.sstatic.net/M6xdd.jpg

  • 2
    Is UA collecting page views and it is just events that are not working or are both page views and events not working? Nov 16, 2021 at 7:56
  • 2
    How are you testing a new container on a site where the old container is still in place? I think that may have thrown a wrench in the preview debugger.
    – BNazaruk
    Nov 22, 2021 at 15:34
  • @BNazaruk I've removed the old GTM ID and replaced it with the new GTM ID.
    – mrjayviper
    Nov 25, 2021 at 23:48
  • 2
    ok, then let's debug, but first - add screenshots of the tags, triggers and variables that you're using. Especially if you use CJS vars. Also, the screenshot of the preview where they don't fire on the summary view. A full screenshot, don't cut it.
    – BNazaruk
    Nov 26, 2021 at 0:06
  • 1
    This is much better. Try doing the preview in incognito mode. I wanna exclude the probability of plugins interfering.
    – BNazaruk
    Nov 26, 2021 at 5:44

1 Answer 1


Looks like you didn't debug it properly.

When a tag is not triggered, the best place to start would be the GTM preview debugger. In it, you attempt to trigger your tags, then you select the event on the sidebar that was supposed to trigger your tags and confirm that only one tag was triggered.

Then, while keeping this event selected, you go to the tag that should have, but did not fire and click on it. It will open the details of this tag, including some information on the tag's trigger. In that trigger information, the preview gives you details into what trigger fired and what didn't and why. Show us the results of that debugging if you still have issues after seeing that.

  • I edited the my original post. Please re-read. Thank you.
    – mrjayviper
    Nov 22, 2021 at 2:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.