1

I have a new website for which I setup Google Analytics, Google Search Console and Bing Webmaster Tools. These were setup last week Wednesday (5 days ago at time of writing).

I submitted the sitemap to Bing Webmaster Tools and Google Search Console. Bing works perfectly and is happy with the sitemap.

Google search console sais Sitemap can be read, but has errors and then goes on to say This url is not allowed for a Sitemap at this location. Here's a screenshot:

enter image description here

My sitemap is at the root, ie: www.example.com/sitemap.xml. Here it is:

<?xml version="1.0" encoding="UTF-8"?>
<urlset xmlns="http://www.sitemaps.org/schemas/sitemap/0.9">
  <url>
    <loc>https://www.example.com/</loc>
    <changefreq>weekly</changefreq>
    <priority>0.5</priority>
  </url>
  <url>
    <loc>https://www.example.com/pricing/</loc>
    <changefreq>weekly</changefreq>
    <priority>0.5</priority>
  </url>
  <url>
    <loc>https://www.example.com/contact/</loc>
    <changefreq>weekly</changefreq>
    <priority>0.5</priority>
  </url>
  <url>
    <loc>https://www.example.com/faq/</loc>
    <changefreq>weekly</changefreq>
    <priority>0.5</priority>
  </url>
</urlset>

When setting up Google Search Console you can select Domain Verification or URL prefix. I selected Domain Verification. However since getting the above error I also tried URL prefix which results in the same issue.

I only have 4 urls on the website and so I went to URL inspection and requested indexing for each of them manually. The next day I came back to check and they are all now indexed correctly.

Please note that I do have a robots.txt in place as follows:

User-agent: *
Disallow:
Sitemap: https://www.example.com/sitemap.xml

So it appears as though my site and all urls are indexed correctly, it is just the sitemap that search console is complaining about. As mentioned, Bing webmaster tools is happy with the sitemap and I am confident it does not contain errors because it is generated automatically by my backend.

Do I need to be worried about this or can it be safely ignored? I'm not sure what else I can do since my domain verified correctly and the urls I submitted manually are now indexed?

11
  • Does your sitemap start with the line <?xml version="1.0" encoding="UTF-8"?>? Is that missing, or did you just not copy and paste it in? May 10 at 7:36
  • Yes it does start with that. Sorry for not including it, I have updated the question now to include it.
    – darkpool
    May 10 at 8:04
  • What type of property do you have verified in Google Search Console? Do you have the domain property, or do you have a prefix property. If it is a prefix property, what is the prefix? May 10 at 8:43
  • On a side note, you should remove the changefreq and priority fields from your sitemap. Google doesn't use them. They just make the file unnecessarily large. May 10 at 8:45
  • Ok I'll remove the changefreq and priority. I have the domain property because I also have sub domains however those are not in the sitemap and I have not added them to search console. I have example.com and support.example.com which is why I registered the domain property for example.com. But as mentioned my sitemap only contains the above listed urls for example.com
    – darkpool
    May 10 at 9:07
2

You have a typo in the domain of the sitemap URLs.

Your canonical hostname is www.feederloop.com, but you are using www.feederlop.com (one o) in your sitemap URLs, which is indeed invalid.

1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.