3

I'm using a URL shortener to publish pronounceable URLs for my pages so I can tell people something like, "Visit mydomain.com/slug to solve that problem." If people go to the address bar of their browser and enter the mydomain.com/slug URL there, then the shortened URL works, and it redirects them to the intended destination page. But if a non-technical user goes to the Google search page and enters mydomain.com/slug into the search box there, Google apparently isn't smart enough to recognize that they typed in a URL. It tries instead to search for the URL as keywords and comes back with a list of search results -- which don't include the page that URL redirects to.

When I click "New Tab" in my browser, I know the difference between the address bar and the search box, but many non-technical users don't, and Google gives the same instructions in both places. Both locations claim to accept both search terms and URLs, but apparently they have different logic for determining which is which. For them to behave differently and not follow the URL when it's typed into the search box instead of the browser address bar seems to be a fatal flaw in the entire concept of shortened URLs - unless there's something else I can do to make them work regardless of which field someone types them into. Certainly I can't be the only one facing this.

What can I do to teach Google that my shortened URL is indeed a URL and when someone types it in the search box, it should go to the place where that URL redirects to?

3
  • A couple of concrete examples are edifyhub.com/fbfi and bbclilburn.org/retreat. Mar 24 at 22:02
  • 1
    I was unable to verify this. When I go to a new tab in chrome and paste your URL into the middle of the page, I get taken to your site. Chrome gives me an option to do a search, but that isn't the default. Screenshot: i.stack.imgur.com/Zp4pw.png The option to search is always available whether or not it is a short URL or a longer URL fully qualified with https://. Mar 26 at 14:45
  • This is embarrassing... I know better than this. Here's my screenshot where the Google Search is the default: i.stack.imgur.com/mMtQW.png The problem is, I forgot to add the .org part when I typed it. As soon as I add the .org part of the address, it instantly switches to default to a direct link. I can only imagine that all those people who have been complaining to me that the link doesn't work have been doing something similar. Mar 27 at 15:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.