1

Let's say I have a site hosted on a.example.com. I'm adding an addon domain to the server (shared hosting): b.example.com and point this domain to the server IP address.

Visiting b.example.com provides the same site as a.example.com, since they point to the same server. That's OK.

Then I'm adding an other addon domain c.example.com and point it to the server IP. When visiting c.example.com I get the error: The requested URL / was not found on this server.

Can you tell me a reason how this could happen? I don't get it.

4
  • Firstly, these are subdomains, not addon domains. Is that what you meant? Next, how long ago did you add the new one? It might just be taking a while for DNS information to propagate. – Steve Feb 28 at 7:38
  • Each hosting account has a main domain assigned (which can be a subdomain too) and addon domains (also can be domains or subdomains) which map to the same hosting account if you want to host more sites on the same account. So addon domain is a hosting concept. Propagation is not an issue here, because it is served via cloudflare, so when I change the IP in cloudflare DNS, it instantly points to the new IP. – Tom Feb 28 at 8:13
  • Can you say more about your configuration? Please edit your question with screenshots of your DNS settings, your cloudflare settings, and your add-on domain settings from cPanel. Any of those could be messed up and causing this problem. It is impossible to know just from the information you provided. Have you use any DNS tools to verify that the DNS is pointing to the same IP address for you various subdomains? If so, please include that information as well. – Stephen Ostermiller Feb 28 at 11:08
  • "The requested URL / was not found on this server." - That would seem to imply a 404? – MrWhite Feb 28 at 18:55

Browse other questions tagged or ask your own question.